• If you are new to these Forums, please take a moment to register using the fields above.


No announcement yet.

Pros/Cons of GTD Netcentrics Outlook Plug-in

  • Filter
  • Time
  • Show
Clear All
new posts

  • Pros/Cons of GTD Netcentrics Outlook Plug-in

    I have been using the GTD Outlook Plug-in for about 6 months now...long enough to go through a couple of releases and upgrades. Bottom line on the product is that is has become an indispensable part of my GTD implementation, and I very much enjoy how easy it makes management of my email inbox, which I continue to better leverage as a central place to route info and data. (As an aside, check out for an example of how I am better using my email inbox)

    With all this said, the product has proven to be very buggy...even the latest version 2.5.21. For example, with the current version, if I put my computer into standby mode (i.e., like right before I go on a plane) and then start it again (i.e., like after we take off and I want to work again), the GTD toolbar often times shows up as grayed out. I have to do a complete reboot of my computer and reopen Outlook to reactivate the toolbar. Another bug I run into is that when I shut down Outlook, Outlook sometimes throws a fatal error and says it wants to to send a message to Microsoft. When I restart the computer and Outlook it tells me the GTD plug-in caused the error and has been disabled. The version before 2.5.21 was even buggier, so there has at least been some improvements.

    Given how much I travel, spending a lot of time trouble shooting with Netcentrics support isn't easy to do. I know because I went through a lot of time with their support dealing with bugs in the last version. Good folks...just not many of them.

    My question to the forum is whether or not others have also found the product as useful, yet as buggy as I have. In other words, I am trying to get a general sense if problems are wide spread, or if there is something specific about my machine that might be causing the problems.

    The amount of time I am in spending on reboots because of the plug-in is something I need to reduce.

    FYI: I am running XP Pro and Outlook 2003.

  • #2
    This is the dilemma of much digital technology. It carries fantastic potential, but the costs of implementing and maintaining it are too often greater than anticipated, and sometimes even outweigh the benefits. For this reason, I try to opt for simplicity over technology and complexity when making decisions about using systems like that.


    • #3
      Re: Pros/Cons of GTD Outlook Plug In

      You are not on your own with the buggy problems. I upgraded to Vista and Outlook 2007 recently and also upgraded to the latest Netcentrics Plug In for Vista. Almost every time I opened Outlook I was getting the message that my outlook data file had not closed properly and was been checked for errors. I disabled the Netcentrics Plug In and now outlook works OK, it closes down without crashing and restarts no problem.

      With outlook 2007 and now Mindmanager 7 I have found that I do not really need to use the plug in so i think i will see how things go without it.


      • #4
        I am also running MS Business Vista with MS Outlook 2007. The GTD add-in has not worked from the moment I loaded it. I did go back to the Netcentrics web page and downloaded the latest version. Nothing doing. I finally just gave up and am implimenting GTD by customizing Outlook.


        • #5
          Same experience

          I've experienced exactly the same issues since migrating to Outlook and downloading the add-in. I love the extra capability....but the frequent reboots are a real annoyance.


          • #6
            I found the addon to be a great initial guiding light, much like ThinkingRock is to others, but eventually found working with it and its bugs too much overhead.


            • #7
              Just to put some balance into this post:

              I really enjoy the addon and have not had any bugs. I find certain functions in the software to be indespensible --- especially linking NA's with projects and being able to drag and drop projects to someday/maybe and back again seemlessly.

              I've had questions about using the software -- and Netcentrics was able to guide me through no problem.

              Great software, and excellent customer service.



              • #8
                I'll second that

                I've used the Netcentrics add-in off and on since the very beginning. (The off phases when I've tinkered around with other approaches.) I find the more recent versions quite useful. And I very, very rarely experience any instability issues.... certainly no moreso than with any other piece of software. I would guess that perhaps once a month Outlook decides to disable the add-in, which requires me to re-enable it and it then runs fine. FWIW, my main desk computer is running version 2.7.5 of the add-in with Outlook 2007 (which I really like) on an aging Pentium 4 with XP. For me, it's worked as advertised.

                Oh... damned nice photos, Mr. Oakley!
                Last edited by smithdoug; 08-11-2007, 11:55 AM. Reason: addendum


                • #9
                  Netcentrics Add- On

                  I have used the Netcentrics add - on since it first appeared. I had troubles with earlier versions but the latest has been absolutely fantastic. I have the Netcentrics add- on in Outlook 2003 and rarely experience any issues. The add-on is super powerful as a workflow tool. I also have Prophet 4.0 (CRM from loaded on Outlook. The system works fine much to my amazement. This combination has been a superb toolset for my small business/consulting practice.


                  • #10
                    Issues W/ Plug -In - Reboot causes loss of projects

                    My problem with the Plug-In is every couple of months it reinstalls itself and then I lose my Project List from the GTD toolbar. I then have to retype all of the projects back into the "Open Project" toolbar if I want to contine to use the plug in.
                    Has anyone else experience this issue and more importantly solved it.